To use our managed IT and Microsoft 365 services your hardware fleet must support the following minimum specifications. Customers are free to procure devices however they wish, but do so at their own risk. Devices procured via Vorco are guaranteed to be compatible at time of purchase. 

Over time the minimum requirements will be raised as technology progresses. We advise that when purchasing hardware that you exceed the minimum requirements in order to get longevity out of your investment.

Minimum Requirements

Windows Devices

Windows 10 Pro or Windows 10 Enterprise on the most recent semi-annual channel release.
Trusted Platform Module (TPM) 2.0. Some older TPM 1.2 modules can have their firmware upgraded to support TPM 2.0.

macOS Devices

We do not fully support macOS devices, for example deployment of software and configuration to these devices has very limited support. If the customer must use macOS then macOS 10.14 or later is required and there may be limits to the amount of support we can provide.
Bootcamp is not supported because we require a TPM module, which Apple do not include in their devices.

iOS Devices

Any device that supports the latest iOS release (currently iOS 13).

Android Devices

Any device that supports Android Enterprise. See https://androidenterprisepartners.withgoogle.com/glossary/device/ for advice from Google on recommended versions (currently Android 8.0+).
Note: Android devices manufacturers often sell old devices with old versions of Android software on them which we do not support.

Windows Devices

Microsoft Surface (commercial models) and HP EliteBook ranges.

macOS Devices

Apple MacBook Air & MacBook Pro ranges.

iOS Devices

iPhone & iPad Pro ranges.

Android Devices

Samsung Galaxy S series and Galaxy Note series.

Did this answer your question?